How can we improve the Oculus Rift platform?

Allow non-SSE4.2 CPU to work with Rift even though it has no Support Help and not passing specs

Having had my Xeon Quad Duo 3GHz perform very well with CV1 for 3yrs now with a GTX970 then GTX1080, Oculus blocked it in 1.32 Runtime. You know about the cpu install hack and it should have been allowed to still work but they blocked the completion of install in the LibrarianServer.
Although I begin again with Rift today with a new (£1200) XPS8930 i7 8700, I still feel strongly that Blocking older cpu was very wrong. Only LONE ECHO uses SSE4.2 which even has it's very own cpu check after the install!
Be good and allow PCs to do what they can and let us run our own systems. This verges on a Lawsuit for discrimination and unnecessary forced sales of new tech. I still wish to run a 2nd Rift in my home! Let it be as it has been for 3years ok? It does nobody any harm to do this!

2 votes
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)

We’ll send you updates on this idea

Macman shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

0 comments

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...

Feedback and Knowledge Base